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Introduction

This is a tutorial on using Xway. We are going to create a document that is 
adapted from the Ambient template for Freeway (Xway’s predecessor), and 
use this as the basis of a second document that has a light theme. You will use 
some images that are in the Media folder which accompanies this tutorial.

Note: This tutorial has been updated for Xway 1.1. If you are using an earlier version 
of Xway, please update to the latest version. Click on About Xway (in the Xway 
menu) if you are not sure which version of Xway you are using.

One of Xway’s strengths is that it makes it easy to create flexible web pages 
that will look good on different devices. After you have worked through this 
tutorial you should have a good basic understanding of how to use Xway—
but there are many topics that we can’t cover in a short tutorial. If you haven’t 
already done so, we recommend that you read (or skim) through the 
introduction to the Xway User Guide (which you can access from Xway’s Help 
menu) and dip into some of the other chapters.

The tutorial is divided into sections, and later sections build on earlier 
sections. You don’t need to work through the whole tutorial in a single 
session.

Text and graphics for the tutorial can be found in the Text and Media folders 
that accompany this tutorial. To import a text snippet, choose Text from the 
Insert menu (shortcut: ⌘Y).

Note: If you copy text from a PDF version of the tutorial, paragraphs may be broken 
into separate lines, which become separate paragraphs when the text is pasted into 
Xway or another application.

This is what the finished home pages look like in a desktop browser and on a 
phone:
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Creating a master page

Let’s start by designing a master page that provides basic layout and shared 
content for the actual pages.

The first step is to create a new document. Start Xway and choose New from 
the File menu if a new document hasn’t opened automatically. You should see 
a new document with a blank page. On the left of the page is the Site panel. 
This contains two root folders: a Master Pages folder that initially contains a 
single master page, and a Site folder that contains a single site page. Master 
pages act as templates for site pages, while site pages are the actual pages in 
your website.

On the right of the page there is an Inspector panel. At this point, the Inspector 
panel should contain two inspectors: a Document Inspector represented by a 
circle icon and a Page Inspector represented by a page icon.
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The Page Inspector shows basic information and properties for a page. In this 
case, it tells us that the page doesn’t yet have a title, but it does have a file 
name: index.html is a special name indicating that this is the default page that 
is displayed when someone follows a link that does not include the name of a 
specific page. Typically, this is the home page of a website (or website folder). 
Click in the Title field and set the page title to Home (and press Return). The 
page title is used to identify pages in a browser’s tab bar and in its history, so 
you might want to use a more descriptive title for a real website—a company 
website might use the name of the company.

The Page Inspector also tells us that this page is based on a master page 
(Master 1). Changes that are made to a master page are inherited by the pages 
that are based on it, except where master inheritance is turned off, via a Use 
Master checkbox. This is where we want to start designing our website. Switch 
to this master page by clicking on Master 1 in the Site panel, and click on the 
disclosure arrow next to it, so that its contents are visible. It is also a good idea 
to close the Home page in the Site panel, to prevent any possible confusion 
while working on Master 1: click on the disclosure arrow next to Home, so that 
its contents are hidden.

Now look at the Page view, between the Site panel and the Inspector panel. It 
contains a single box (called pagediv) that takes up most of the Page view. 
Click on this box (or click anywhere in the middle of the Page view) in order 
to select it. You should be able to see some selection handles, showing that the 
box is selected—but if you have a small screen, these handles will be at the 
edges of the Page view. If you look at the Inspector panel to the right, you 
should see that it now contains another inspector: the Box Inspector.
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Xway’s Inspector panel is contextual. It shows you what is currently selected, 
and it also shows you some of the selected item’s ancestors: when a box is 
selected, Xway also displays a Page Inspector for the page that contains the 
box, along with the Document Inspector (which is always shown).

Master page layout
While the page div is selected, click in the Name/ID field and change its name 
to page-wrapper.

Now go to the Document Inspector (click on the circle icon) and look in the 
section that is called Document: Pagediv Dimensions. Within this section, 
change Maximum Width to 960px. What this does is to change the default 
maximum width of every page div in the document. In addition to regular 
master pages, Xway documents contain an internal document master page from 
which default values for individual pages (including master pages) are 
derived. You cannot see this page (and its page div) directly, but you can use 
the Document Inspector to change its styles. Setting the maximum width here 
(rather than on individual pages) allows you to make a single change if you 
want to use a different value at a later date.

When you have changed the maximum width of the page div in the Document 
Inspector, change its minimum height from 100% to 96vh. Here, vh is a CSS 
measurement that represents 1% of the viewport height (“viewport” is the 
content area of a browser). So a minimum height of 96vh sets page-wrapper to 
be (at least) 96% of the full height of a browser’s content area

Now click on the Background Color popup in the Document: Pagediv Style 
section and choose Other. This will display the New Color dialog. Type 
Charcoal as the Name of the color, and type 111111 as the Hex value. Press 
Return (or Tab) to accept the Hex value, and click on OK (or press Return) to 
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dismiss the dialog. Then, in Document: Pagediv Margins, set Top Margin to be 
2vh.

What you should now see is a charcoal-colored page-wrapper (page div) on a 
white page background, centered vertically on the page with a small margin at 
the top and bottom. The next thing that we are going to do is to change the 
page background. Click on the Background Color popup (which currently 
shows White) in the Document: Style section of the Document Inspector and 
select Other. In the New Color dialog type Blue-Gray as the Name of the color 
and type (or paste) 8491a4 as its Hex value. Press Tab or Return to accept the 
Hex value, and OK the dialog. You should now see that the page has a blueish 
gray background.

Before we leave the Document Inspector (for now) there are two more things 
that we need to do. Beneath Document: Style you should see a section called 
Document: Text. Open this section by clicking on it. Then click on the Text Color 
popup and choose White. If we don’t do this, it will be hard to read black text 
on a charcoal background! While we’re in this section, let’s also change the 
font from Serif to Helvetica, so that text is displayed in Helvetica (or another 
sans-serif font if Helvetica is not available).

Now click on Master 1’s page-wrapper (the page div) in the Page view if it is 
not already selected. Then click on it a second time in the Page view (or press 
Command-Return) to start editing. What we want to do is to insert three items 
in page-wrapper: a header, a main section, and a footer.

If you can’t see a text insertion point within page-wrapper (it should be 
flashing at the top left) move the mouse cursor over it and check that it 
changes to an I-beam (text editing) pointer:
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Next, click on the Insert Box tool in the toolbar (this is the leftmost Insert tool, 
whose icon is an empty box). This will insert a box called item1. Click twice 
more until you have three boxes: item1, item2, and item3. These are container 
boxes. In Xway, container boxes contain text and other boxes.

Now click on the first box (item1) and use the Type popup in the Box Inspector 
to change its type from Div to Header. Xway renames it as header1, but we’re 
not going to create any more headers, so we might as well remove the number 
at the end and rename it to header. Then click on the second box (item2) and 
change its type to Main, using the same popup. Xway renames this box as main 
(it doesn’t add a number, because you are not supposed to have more than 
one main section on a page). Finally, click on the third box (item3), change its 
type to Footer, and remove the number from the end of its name, so that it is 
now called footer.

Note: Dividing a master page into sections (and subsections) is good practice for 
accessibility reasons, and is also a helpful way of separating content that will be shared 
by other pages (the header and footer sections) from content that is unique to each 
page (the main section). Doing this allows you to change page-specific content in one 
section without breaking the link between master content and instance content in 
other sections.

Master page header
Next, let’s turn to the header. Select it in the Site panel or Page view and open 
the Padding section in the Box Inspector (click anywhere in the section header). 
Set the left and right padding values to be 2%. Then click inside the header 
box, so there is a text insertion point, and add two boxes (using the Insert Box 
tool in the toolbar). Rename the first box as brand and change the type of the 
second box to Nav, then rename it as navigation.
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Brand box

The first box (brand) is going to contain some company branding. Click inside 
it so there is a text insertion point, and insert the following text by choosing 
Text from the Insert menu (shortcut: ⌘Y) and importing snippet 1 from the Text 
folder that accompanies this tutorial:

Xway

Softpress: Making web design easy since 1993

In Xway, the text should show up as white text on a dark background. If it’s 
black (and unreadable), you need to go back and set the default text color to 
be white (see page 10 above, text beginning “Before we leave the Document 
Inspector”).

Now click somewhere in the first paragraph (“Xway”), and the Inspector panel 
should display the Paragraph Inspector (immediately after the Box Inspector).

Change the paragraph type from Paragraph (normal paragraph) to Heading 1, 
and notice how it is now displayed in a larger font (as is normal for headings). 
Let’s also make the text be centered: select all the text that is in this box (Select 
All in the Edit menu) and click on the Center Align icon in the Paragraph 
Inspector.

“Xway” is quite close to the top of this box, so let’s add some padding. Go to 
the Box Inspector and enter 1px as Top Padding. You will notice that this has the 
effect of adding considerably more than one pixel’s worth of space. This is 
because of a CSS feature known as “collapsing margins”. What happens is 
that CSS collapses the vertical margins (vertical space) that precede and follow 
paragraphs and container boxes. In this case the vertical margin before 
“Xway” (normally) collapses with the vertical margin before its parent box 



Creating a master page 13

(brand), and that margin also collapses with the vertical margin before its 
parent boxes (header and page-wrapper). Adding some padding to the top of 
the parent box prevents this from happening, so the space that you see is one 
pixel of padding plus the vertical margin that normally precedes a paragraph 
or heading.

If you want, you can confirm that this spacing is also visible in a browser. 
Recent versions of Safari are unable to display pages from unsaved 
documents, so let’s begin by saving the document. Choose Save from the File 
menu (shortcut: ⌘S) and save the document in a suitable location, naming it 
Ambient. Then choose Preview from the File menu (or use the shortcut ⌥⌘B). 
This will cause the page to be displayed in your default browser. You should 
see that the browser adds the same vertical spacing that you see in Xway. Go 
back to Xway and choose Undo Top Padding from the Edit menu, then preview 
again. Notice how “Xway” is close to the top of the page-wrapper box, as it is 
in Xway. Go back to Xway and choose Redo Top Padding from the Edit menu.

In that last paragraph, “This will cause the page to be displayed in your 
default browser” is not completely accurate. Since we are on a master page—
and master pages are not published—Xway actually previews the first 
available site page instead of the master page. It comes to the same thing in 
this case, because we haven’t started editing any site pages.

While we’re setting padding, let’s set the bottom padding value to be 1px, so 
that the bottom margin doesn’t collapse either. Check that brand is selected in 
the Site panel (it should be if you haven’t clicked anywhere else) and enter 1px 
as Bottom Padding in the Box Inspector.

Let’s make a few more changes to the text in the brand box. It would be nice if 
“Xway” was a bit larger. Put a text insertion point somewhere inside it and go 
to the Size field in the Text section of the Paragraph Inspector. This currently 
shows 2em (if you see a different value, check that your are looking at the 
Paragraph Inspector and not the Box Inspector). Type 2.4 in this field, so that 
the size is now 2.4em (you don’t need to type a measurement, because Xway 
uses the measurement that is already set). An “em” is generally equivalent to 
the size of a font, so 2.4em selects a font that is 2.4 times the size of the base 
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font size (the base font size is the font size that is typically used in 
paragraphs). The brand slogan (“Softpress etc.”) could also be larger, so put a 
text insertion point in it and type 1.2em in the Size field: you do need to type 
em in this case, because Xway will default to pixels if there isn’t a 
measurement already!

Now let’s make a couple of final tweaks to the brand box:

1. Select the “Soft” in “Softpress” (as you would in any text editor). Xway now 
displays two additional Inspectors: the first is the Link Inspector (which we’ll 
ignore for now) and the second is the Span Inspector. The Span Inspector 
allows you to change the style of inline text runs (spans). Choose Bolder from 
the Weight popup, so that “Soft” is displayed in a bolder font weight. Then 
select “press” in “Softpress” and choose Lighter from the Weight popup. This 
creates a branding effect that matches our “Softpress” logo.

You might notice that when you changed the style of “Soft” and “press” the 
Type popup changed from None to Span. Adding a style attribute to a run of 
text creates a span element if there wasn’t one previously. There are other 
types of span elements (using “span” in a general sense) in addition to span 
(in a strict sense). If you want a word or phrase to be emphasized (and 
typically displayed with italics) you could choose Emphasized from the Type 
popup.

2. Let’s reduce the vertical space between “Xway” and the following slogan. 
Place the text insertion point somewhere in the slogan and change Top Margin 
to 0em in the Paragraph Inspector. Nothing happens, but that’s because the top 
margin was already collapsed with the bottom margin of “Xway”. We’ve 
encountered collapsing margins before, but this is a simple case: when a 
paragraph follows another paragraph (or heading) CSS collapses the bottom 
margin of the first paragraph (or heading) with the top margin of the second 
paragraph—by choosing whichever is greater. In this case the bottom margin 



Creating a master page 15

of the Xway heading is greater than the top margin of the slogan paragraph, 
so the top margin of the slogan paragraph has no effect. But, having removed 
the top margin of the slogan paragraph, we can now determine the space 
between the two paragraphs by changing the bottom margin of the first 
paragraph. Place the text insertion point somewhere in the first paragraph 
(“Xway”) and change Bottom Margin to 0.3em. If we wanted more or less space 
between the two paragraphs, we could change the bottom margin of the first 
paragraph to a smaller or greater amount (the top margin of the second 
paragraph has been set to zero so it has no effect).

Note: Why is the (original) bottom margin of the heading greater when it is 0.67em 
and the top margin of the paragraph is 1em? This is because an em is a relative 
measurement, and 0.67 of the larger font size (of “Xway”) is greater than 1 of the 
smaller font size (used in the slogan).

Navigation box

Let’s turn our attention to the navigation box. Select it and set the top and 
bottom padding to be 1px. Then click inside it and type or import the 
following text (snippet 2):

HOME | NEWS | ABOUT | GALLERY | CONTACT

We’d like this to be centered. We could do this using the Text section of the  
Paragraph Inspector, as before, but another way to do this is to use the Text 
section of the Box Inspector, which affects all text within a box (not just a single 
paragraph). It makes no difference in this case, but let’s use the Box Inspector. 
Switch to the Box Inspector, and open the Text section just below the Padding 
section. Choose Center Align from the Align icons. Now the text is centered. We 
also want to use a different text color, so choose Blue-Gray from the Text Color 
popup. While you’re here, choose Lighter from the Weight popup (just above).

Now scroll up in the Box Inspector and delete the Minimum Height value in the 
Dimensions section, so that the box shrinks to the height of its contents. We can 
also remove Minimum Width at the same time (it’s not needed).
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Master page main section
We can mostly ignore the main section for now, because this is designed to 
hold different content on each page, but one thing that we can do is to set 
some padding. Select main in the Site panel and type 2% for both Left Padding 
and Right Padding in the Box Inspector.

Master page footer
Let’s go to the footer. What we want to do here is to add some social media 
icons and a copyright notice. We’d also like everything in this box to be 
centered. Select footer in the Site panel, then go to the Box Inspector and choose 
center alignment in the Text section (as we did previously).

Click inside the footer and type or import the following text (snippet 3):

© Copyright

All Rights Reserved

This is another case where we want to reduce the amount of space between 
these two paragraphs (for visual effect and to show that they belong closely 
together). We can use the same technique that we used previously: put the text 
insertion point in the second paragraph and use the Paragraph Inspector to set 
its top margin to zero (so it has no effect), then move the text insertion point 
into the first paragraph and set its bottom margin to 0.5em.

Next, move the text insertion point into the second paragraph (anywhere 
within the paragraph) and use the Insert Box tool to insert a container box. 
Because it’s not possible for a container box to be inserted within a paragraph, 
Xway will automatically insert it after the paragraph that contains the text 
insertion point. Rename this box as media, and insert a text insertion point 
within it.

Now click on the Insert Graphic tool in the tool bar (next to the Insert Box tool) 
and choose facebook.png from the Media folder that accompanies this tutorial. 
After you have done this (and without changing the selection), insert the 
following graphics in the same way: x.png, linkedin.png, flickr.png, tumblr.png, 
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instagram.png, pinterest.png, dribbble.png, youtube.png, vimeo.png, 
soundcloud.png, and skype.png.

While the last graphic is still selected, choose Select All from the Edit menu 
(shortcut: ⌘A) to select all the graphics. The graphics don’t need to be as large 
as they currently are, so we will shrink them to half their current size. If you 
look at the Content section of the Box Inspector, you can see that their current 
size is 76 × 76 pixels—so type 38px (76 ÷ 2) in the Width field of the Dimensions 
section of the Box Inspector. There is another reason for doing this: on high-
resolution screens, graphics look better if they are displayed at half their 
natural size (or smaller).

Note: You don’t need to change the height of these graphics when you change their 
width. This is because CSS (and Xway) preserves the original aspect ratio (width to 
height ratio) of a graphic when only one dimension is defined.

While the graphics are selected, change their maximum width from 50% (this 
is a default value that Xway uses) to 8% in the Maximum Width field of the 
Dimensions section of the Box Inspector. There are twelve social media 
graphics and 12 times 8% is 96%. This ensures that the graphics will fit on a 
single line if you view the page on a narrow screen, such as a phone. Setting a 
maximum width of 8% means that no graphic will be wider than 8% of the 
width of its parent (the media box).

Let’s add some links to these graphics. Select just the Facebook graphic 
(Command-click on it to deselect it and then release Command and click a 
second time to select it and deselect the other graphics) and choose Link from 
the Format menu (shortcut: ⌘K). Choose External from the Link Type popup 
and enter www.facebook.com in the URL field. Then choose HTTPS from the 
Protocol popup. We’re going to do the same with the following graphics, and 
we don’t actually need to set the protocol because we can do that afterwards 
(see below), but a nice touch would be to type the media name into the Title 
field. Link titles are displayed as help tags in browsers, so if it’s not obvious 
what the various icons stand for, users can position their mouse over the icon 
and the browser will display the link’s title. Type Facebook into the Title field, 
and OK the dialog. Now select each of the following graphics in turn, and set 
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links and titles on them: www.x.com, title: X (Twitter), www.linkedin.com, title:  
LinkedIn; www.flickr.com, title: Flickr; www.tumblr.com, title: Tumblr; and so on.

Note: An easy way to select the next graphic in an adjacent series of graphics is to 
press the right arrow twice: pressing once will move the text insertion point after the 
first graphic, and pressing again will select the following graphic.

When you’ve entered the URLs (and titles), select all the images once again 
and click on the Link Inspector icon (to the left of the Box Inspector icon) if it’s 
not already selected. Select HTTPS as the protocol, and click on the Open in 
New Window or Tab checkbox—so that these links will open within a new 
window or tab.

Now that we have added content to the media box, we can remove its 
minimum height, so the box will shrink to fit its content. Select it in the Site 
panel, and delete the Minimum Height (and Minimum Width) values in the 
Dimensions section of the Box Inspector.

To create some space at the top and bottom of the footer box (the box which 
contains the media box), select it in the Site panel and set its top and bottom 
padding to 1px in the Padding section of the Box Inspector.

Link styles
There is one last thing that we want to do before we start creating actual 
pages, and that is to set some link styles that will be used in the document. Go 
back to the Document Inspector and open the Document: Default Styles section. 
Choose Link from the Element popup, and you can see that links are typically 
displayed with blue text. That’s not going to look good with the colors we’re 
using, so change Text Color to Blue-Gray. Then, just below, deselect the 
Underline icon for Text Decoration, to prevent links from being underlined by 
default. Now choose Visited Link from the Element popup and change Text 
Color from Purple to Blue-Gray. You don’t need to deselect underline in this 
case—it’s already deselected because visited links share the text decoration 
attributes of normal links. Finally, choose Hover Link from the Element popup 
and turn underlining back on for hover links. This causes links to be 
underlined when the mouse is over them.
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We’d like to use some different link styles in the navigation box. To do this, 
select navigation in the Site panel and go to the Default Styles section of the Box 
Inspector. This allows us to set some default styles that only apply to this box. 
Choose Link in the Element popup, and set Text Color to White. Do the same for 
Visited Link. Then choose Hover Link in the Element popup and turn off 
underlining.

Now is a good time to save your document (name it Ambient if you haven’t 
already done so). Xway documents are automatically saved at regular 
intervals, but if you manually save them you will create versions that you can 
revert to (using Revert To in the File menu).





Creating a Home page 21

Creating a Home page

Now that we have a master page that provides a template for other pages, 
let’s turn to the Home page by by clicking on it in the Site panel. We want to 
add some content that is specific to this page.

Since we’ve finished working on the master page, it’s a good idea to close it in 
the Site panel, to avoid any possible confusion with the Home page (the two 
pages currently look identical and contain the same items): click on the 
disclosure arrow next to Master 1 so that its contents are hidden. We also want 
to open the Home page if it’s currently closed: hold down the Option key and 
click on the disclosure arrow next to it (this is a standard Mac shortcut for 
opening a list item along with its contents).

Home content
Now select the main item on the Home page (in the Site panel) and press Tab to 
switch to the Page view. Press Command-Return to insert a text insertion point 
into main. (You can also press Command-Return without pressing Tab first—it 
will do the same.) Once you’re inside main, click on the Insert Graphic tool in 
the toolbar and choose hero-image.jpg from the Media folder. Delete the 
maximum width that Xway sets, and then set the width (not the maximum 
width) to be 100%.

While the graphic is selected, click on the Insert Box tool in the toolbar, so that 
Xway will insert a container box after the graphic. At the top of the Box 
Inspector, set the Type of this box to Section, then choose Duplicate Selection 
from the Edit menu (shortcut: ⌘D). You should now have two boxes following 
the graphic: section1 and section2. Import the following text (snippet 4) into 
the first box (section1):
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Nulla facilisi. Duis aliquet egestas purus.

Pellentesque eu est a nulla placerat dignissim. Morbi a 
enim in magna semper bibendum. Etiam scelerisque, 
nunc ac egestas consequat, odio nibh euismod nulla, 
eget auctor orci nibh vel nisi. Aliquam erat volutpat. 
Mauris vel neque sit amet nunc gravida congue sed sit 
amet purus. Quisque lacus quam, egestas ac tincidunt 
a, lacinia vel velit. Aenean facilisis nulla.

This is some meaningless placeholder (Lorem Ipsum) text. Put a text insertion 
point in the first paragraph, and change the paragraph type to Heading 2 (in 
the Paragraph Inspector). Then import the following text (snippet 5) into the 
second box (section2):

Maecenas nec urna et dolor dictum consequat. 
Phasellus eu iaculis sapien. Ut in lobortis eros, ut 
dignissim massa. Quisque non auctor urna, eget 
hendrerit nulla. Praesent libero leo, iaculis eu cursus 
at, molestie vitae urna.

When you’ve pasted text into both boxes, go to the Box Inspector and remove 
the minimum heights (and widths) that Xway set. You can do this by selecting 
both boxes and deleting the Minimum Width and Minimum Height values in the 
Dimensions section.

Now select main in the Site panel, and look at the Content section in the Box 
Inspector. You will see that the Use Master Content checkbox has been turned 
off, because it no longer contains the same content as its master box (main on 
Master 1).

Try turning this checkbox back on, and you will see that main’s content 
disappears! (There isn’t any content in the master box.) We don’t want that to 
happen, but it doesn’t matter because we can get the content back by choosing 
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Undo Use Master Content (shortcut: ⌘Z) from the Edit menu. Do that now. 
Xway has unlimited levels of undo/redo, and almost anything that you do 
can be undone and redone.

Linking to the Home page
Now go back to the master page (Master 1) by clicking on it in the Site panel or 
by choosing Master Page from the Go menu, and double-click on “HOME” in 
the navigation box (so that it is selected). Choose Link from the Format menu 
(shortcut: ⌘K), and select Home from the Page popup, then click OK or press 
Return. “HOME” should now be displayed in white text, because that’s how 
we set the link styles for this box.

Return to the Home page (by clicking on it in the Site panel), and you should 
see that the link is also applied on this page.

Previewing the Home page
Let’s see how the Home page will look when it is published.

We could preview it in a browser (as we did previously), but a quicker way to 
preview single pages is to click on the Web Preview button in Xway’s toolbar 
and preview within Xway. This displays the page using WebKit (the browser 
engine used by Safari).

Xway’s internal Web view is useful if you want to see what a page will look 
like in a browser, but you don’t want to follow links to other pages. Xway 
publishes the current page (instead of the entire site) and the internal Web 
view ignores links to other pages.

Go back to the Page view, either by clicking on the Page button to the left of 
the Web view button, or by clicking on the Go Back button in the toolbar 
(shortcut: ⌘[ ).



24 Creating a Home page

Note: Xway’s Page and Web views are flexible—you can resize them by dragging the 
dividers that separate them from the Site panel and Inspector panel. This lets you see 
how a page will look on different devices.
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Creating a News page

Close the Home page in the Site panel (by closing the disclosure arrow next to 
it). Then insert a new page by choosing Page from the Insert menu, and name 
it News (type News in the New Page dialog).

News content
Now select the main section of this page in the Site panel and place a text 
insertion point inside it by pressing Command-Return. Use the Insert Box tool 
to insert a container box, and change its type to Article, using the Type popup 
near the top of the Box Inspector. Duplicate this box twice by choosing 
Duplicate Selection from the Edit menu (shortcut: ⌘D), so that you have three 
boxes within main: article1, article2, and article3. Import the following text 
(snippet 6) into the first box:

Lorem ipsum

Dolor sit amet

Consectetur adipiscing elit. Nam convallis dignissim 
ullamcorper. Vivamus commodo sem metus, a 
pretium metus porta fringilla. Aenean pulvinar arcu 
vitae mi vestibulum, ut suscipit ipsum commodo. Cras 
sit amet fringilla dui, eu viverra erat.

More…
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Then import the following text (snippet 7) into the second box:

Sed egestas neque arcu

Proin non magna quis erat bibendum 

Nam ultrices vestibulum felis, ac imperdiet enim 
iaculis sagittis. Nulla congue dapibus velit, sit amet 
pharetra est commodo facilisis. Nulla cursus 
scelerisque ultrices.

More…

Then import the following text (snippet 8) into the third box:

Donec semper mi id

Faucibus vehicula augue pulvinar

Phasellus lobortis feugiat magna, eleifend auctor 
neque. Etiam non ligula vitae felis sodales accumsan 
vitae a nulla. Etiam id libero accumsan, dapibus ipsum 
at, tincidunt leo.

More…

Within each box, set the type of the first paragraph to be Heading 2 and the 
type of the second paragraph to be Heading 3. Do this by placing a text 
insertion point in the paragraph and selecting Heading 2 or Heading 3 from the 
Type popup in the Paragraph Inspector. Then go to the Document Inspector and 
change the default text color for Heading 3 within the Document: Default Styles 
section: choose Heading 3 from the Element popup and select Other from the 
Text Color popup. Enter Gray-Teal as the name and 437286 as the hex value. 
Press Tab or Return to accept the hex value, and then click on OK (or press 
Return) to dismiss the dialog.

Finally set a link on the “More…” paragraph at the bottom of each box. This 
could point to a page that contains a complete news article, but for now you 
can just link it to the current (News) page. Select “More…“ within each box, 
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then choose Link from the Format menu (shortcut: ⌘K), and select News from 
the Page popup, then click OK or press Return.

Preview the page in a browser or in Xway’s Web view. You should see that the 
“More…” links are underlined when you move the mouse over them.

Note: If the “More…” links aren’t underlined, look at the Default Styles section in the 
Page Inspector, and check that the Use Master Default Style checkbox is turned on 
when you select Link, Visited Link, and Hover Link in the Element popup. If it’s not 
turned on, the link styles that were defined for the master page are being overridden by 
default styles on the page. Turning this checkbox back on (for each link style) will 
reconnect the page link styles with the master page’s default styles. If the the links still 
aren’t underlined when you preview the page, switch to the master page and check 
that the Use Document Default Style checkbox is turned on when you select Link, 
Visited Link, and Hover Link in the Element popup.

Linking to the News page
If you previewed in Xway’s Web view, switch back to the Page view. Now go 
to the master page (Master 1) and double-click on “NEWS” in the navigation 
box (so that it is selected). Choose Link from the Format menu (shortcut: ⌘K) 
and select News from the Page popup.
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Creating an About page

Close the News page (in the Site panel) now that we’ve finished working on it. 
Then insert a new page by choosing Page from the Insert menu, and name it 
About (type About in the New Page dialog).

About content
Click on the main section in this page and place a text insertion point inside it. 
Use the Insert Box tool to insert a container box, and change its type to Section, 
using the Type popup near the top of the Box Inspector. Then click inside 
section1 and import the following text (snippet 9):

Meet some of the team...

Vivamus mollis tincidunt dapibus. Integer molestie 
tincidunt nunc sit amet rutrum.

Phasellus aliquet pretium eros quis aliquet. Nam in 
semper arcu. Praesent sit amet molestie tellus, lacinia 
ultricies orci. Aliquam erat volutpat. Ut gravida nisl 
magna, vel ullamcorper purus sodales et. Pellentesque 
eget scelerisque quam.

Maecenas rhoncus erat vitae odio ultricies dictum. 
Vivamus tellus libero, congue vel urna nec, bibendum 
consectetur quam. Proin volutpat tempor porttitor.

Change the type of the first paragraph to Heading 2. Then place the text 
insertion point at the start of the next paragraph and click on the Insert Graphic 
tool. Insert user.png, and set its width to be 64px in the Dimensions section of 
the Box Inspector. Choose Copy from the Edit menu (shortcut: ⌘C) to copy the 
graphic. Then place the text insertion point at the start of the following 
paragraph and paste the graphic back by choosing Paste from the Edit menu 
(shortcut: ⌘V). When you’ve done this, paste it a second time at the start of 
the final paragraph.
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Linking to the About page
Now go back to the master page (Master 1) and double-click on “ABOUT” in 
the navigation box (so that it is selected). Choose Link from the Format menu 
(shortcut: ⌘K) and select About from the Page popup.
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Creating a Gallery page

Close the About page now that we’ve finished working on it. Then insert a 
new page by choosing Page from the Insert menu, and name it Gallery.

Gallery content
Click on the main section in this page and place a text insertion point inside it. 
Then import the following text (snippet 10):

Our gallery

Aenean pulvinar arcu vitae mi vestibulum, ut suscipit 
ipsum commodo. Cras sit amet fringilla dui, eu 
viverra erat.

Change the type of the first paragraph to Heading 2.

The easiest way to create web galleries is to use Xway’s sister program, 
Exhibeo 2. Exhibeo 2 has an option to export galleries as Xway components. 
These can be imported into Xway by clicking on the Component button in the 
toolbar.

If you have a recent version of Exhibeo 2 (2.0.4 or greater) you could try doing 
this now. Open an existing Exhibeo gallery, and choose Export to Xway from 
the Export menu. This will output an Xway Component (xwComponent) file. 
Click on the Component button in Xway’s toolbar, and select this file. Switch to 
Xway’s Web view to see the gallery working. Then switch back to the Page 
view.

If you don’t have Exhibeo, or if you’d like to learn how to use resource links 
and rollover effects within Xway, you can use the following steps to create a 
simple gallery. If you added an Exhibeo gallery, delete it. Then place the text 
insertion point at the end of main, type Return, and use the Insert Graphic tool 
to insert the following three graphics from the Media folder: anglesey.jpg, 
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glastonbury.jpg, and oakamoor.jpg. Select the three graphics, set their width to 
160px, and set the left and right margins to be 2px. While the graphics are 
selected, press the right arrow on your keyboard (to get a text insertion point), 
and choose the Center Align icon in the Paragraph Inspector, so that the 
graphics are centered.

Select the first graphic and choose Link from the Format menu (shortcut: ⌘K). 
We’ve previously created Page links and External links, but now we’re going 
to create a Resource link. This will link to a resource that Xway publishes. It 
could be a PDF file (which would normally be opened and displayed within a 
browser) or it could be a ZIP file (which would normally be downloaded from 
a browser), but in this case we are going to link to the same image file, so that 
it is displayed at full size when a user clicks on it. Choose Resource from the 
Link Type popup, then click on Other in the Resource popup and choose the 
first graphic (anglesey.jpg) from the tutorial Media folder. Do the same with 
the other graphics (choosing the corresponding graphic in each case).

When you’ve done that, enter the following place names into the Title field for 
each graphic, so that they are displayed as help tags when the mouse is 
paused over them: Trearddur Bay, Anglesey; Glastonbury; Oakamoor, 
Staffordshire. You can paste these titles in the Title field of the Box Inspector or 
in the Title field of the Link Inspector (the effect will be the same), but if you 
paste them in the Box Inspector you can also paste them into the Alt. Text field 
above the Title field. Graphics that are not purely decorative should normally 
be accompanied by alt. (alternative) text.

Preview the page in a browser. If you click on a graphic, the browser will 
display it at full size. (Don’t use Xway’s internal Web view this time, since it 
doesn’t follow links away from the current page.)

Adding a rollover effect
Let’s add a rollover effect to the gallery images, so that they change in some 
way when the mouse is moved over them. Select the three gallery images and 
open the Dynamic Styles section of the Box Inspector. Type 80% in the Opacity 
field. This will cause each image to become slightly transparent (showing 
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some of the background color) when the mouse pointer is over it. With a dark 
background, the effect is that the image will appear slightly darker. Preview 
the page again to see how this looks.

Note: You can also specify a transition, so that (in this case) the image darkens and 
lightens over a period of time. To do this, go back to the Page view and open the 
Extended Properties section above the Dynamic Styles section and click on the + 
button. Enter transition in the Name field and 0.2s in the Value field, then press 
Return. For more information on dynamic styles and transitions, search for “Dynamic 
Styles” in the User Guide (available from Xway’s Help menu).

Linking to the Gallery page
Now go back to the master page (Master 1) and double-click on “GALLERY” 
in the navigation box (so that it is selected). Choose Link from the Format menu 
(shortcut ⌘K) and select Gallery from the Page popup.
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Creating a Contact page

The final page that we are going to add is a Contact page. Contact forms have 
become problematic as a result of anti-spam measures, and Xway doesn’t 
support them directly (although you can add forms that have been created via 
an online form generator). But you can provide contact information via an 
email link.

Close the Gallery page now that we’ve finished working on it. Insert a new 
page by choosing Page from the Insert menu, and name it Contact.

Contact information
Click on the main section in this page and place a text insertion point inside it. 
Then import the following text (snippet 11):

Please get in touch!

You can contact us via email.

Change the type of the first paragraph to Heading 2.

Now double-click on “email” to select it, and choose Link from the Format 
menu (shortcut: ⌘K). Choose External from the Link Type popup, and choose 
Mailto from the Protocol popup. Enter Web query in the Subject field, and 
address@example.com in the To field. Also select the Obfuscate checkbox—this 
makes it more difficult for spam bots to recognize and harvest the email 
address.

Preview this page in a browser: if you click on “email” it should open an email 
titled “Web query” in your email client. Don’t send the email 
(address@example.com isn’t a real address).

Linking to the Contact page
Now go back to the master page (Master 1) and and double-click on 
“CONTACT” in the navigation box. Choose Link from the Format menu 
(shortcut: ⌘K) and select Contact from the Page popup.
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You now have the outline of a complete site. Preview in a browser to check 
that the navigation links are correct. Fix them if they’re not.

Adding a hover style to navigation links
Let’s make one final tweak that shows how easy it is to make site-wide 
changes using master pages. Perhaps we would like the main navigation links 
to change style when the mouse is moved over them. Select the navigation box 
on the master page, and open the Default Styles section in the Box Inspector. 
Choose Hover Link from the Element popup. Now choose Other from the Text 
Color popup, and create a new color called Light Blue-Gray with a hex value of 
d4dbe5.

Preview again in a browser. The navigation links should change color when 
you move the mouse over them.

When everything is correct, save your document.
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Uploading a site

The Xway User Guide (available from Xway’s Help menu) contains instructions 
for uploading a site—see Uploading in Chapter 1 Documents.
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Creating a new theme

The last thing that we are going to do in this tutorial is to create a new version 
of the Ambient document, as a way of showing how easy it is to change the 
appearance of a website with Xway.

Choose Duplicate from the File menu. This will create a duplicate of the 
Ambient document. Call it Ambient Light.

Background colors
Go to the Document Inspector and choose Light Blue-Gray in the Background 
Color popup in the Document: Style section.

Next, click on the Background Color popup in the Document: Pagediv Style 
section and choose White.

Text colors
We now have white text on a white background, which is difficult to read! But 
it’s easy to fix this. Open the Document: Text section and use the Text Color 
popup to change the text color to Charcoal.

Link colors
Most of the text is now readable, but the linked text in the navigation boxes is 
still white. Switch to the master page and select the navigation box on this 
page. We will use the Box Inspector to change the link colors to Charcoal. 
Within the Default Styles section, choose Link from the Element popup, and 
choose Charcoal from the Text Color popup. Do the same for Visited Link. Then 
choose Hover Link from the Element popup and select Blue-Gray from the Text 
Color popup.

Preview this new theme in a browser. Then save the new document: name it 
Ambient Light if you haven’t already done so.
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Further information

If you have worked through this tutorial you should have a good basic 
understanding of how to use Xway. But there are many topics that we can’t 
cover in a short tutorial, and there are several ways to access additional 
information.

Xway tutorials
This is the first in a series of Xway tutorials. The next tutorials in this series are 
the Xway Menu Tutorial and the Xway Flexbox Tutorial. The Xway Menu Tutorial 
introduces menus, and provides steps for adding a navigation menu to the 
Ambient and Ambient Light documents that are created by this tutorial. The 
Xway Flexbox Tutorial introduces Flexbox layout, and provides steps for using 
Flexbox layout in the Ambient 2 and Ambient Light 2 documents that are 
created by the Xway Menu Tutorial. All these tutorials, and the documents they 
create, are available from our website.

There are also short tutorials (tagged “tutorial”) in the Xway discussion forum 
(see below).

Xway user guide
Xway comes with a detailed reference manual, which you can access by 
selecting Xway User Guide from Xway’s Help menu. This contains information 
on a wide range of topics, including: iframes (these can be used to insert maps 
or YouTube/Vimeo videos, and other content), favicons (site icons displayed 
in browser tabs), dynamic styles, fonts, resources, lists, components, 
navigation menus, extended attributes, extended properties, markup, meta 
tags, and so on.

The Xway User Guide also contains appendices with advice on importing 
content from Freeway documents or from an existing website.



42 Further information

Xway discussion forum
Choose Support and Community from Xway’s Help menu to visit the Xway 
discussion forum. This contains Xway-related news and discussions, and is a 
good place to ask questions and get help from us and from other Xway users.

Xway resources
Choose Xway Resources from the Help menu to visit the Xway Resources 
section of our website. This contains links to the latest versions of this tutorial,  
along with other tutorials and completed tutorial documents. There are also 
other resources such as templates.
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